Jump to content

My daughter calls it Toothless the Dragon: My ‘95 TT Z


nickz32

Recommended Posts

9 hours ago, nickz32 said:

Not yet, but completely agree.

 

its going to be hard keeping it this clean with the amount of driving I want to do in it (let’s face it… I’ve got years of pent up z driving) but it’ll be a fun challenge!

Sounds like a road trip needs planning or a driving weekend 🙂

  • Like 1
Link to comment
Share on other sites

  • advertisement_alt
  • advertisement_alt
  • advertisement_alt
Just now, craig said:

Sounds like a road trip needs planning or a driving weekend 🙂

I’ve got a trip up to Snowdon at the end of Sept planned with my two closest mates in their cars (Gen 1 Legacy turbo and a 944) which I’m really looking forward to.

 

ive still got a steering issue that I’ve got to figure out. I think im probably going to strip rebuild the rack as im running out of ideas as to what the problem is

Link to comment
Share on other sites

  • Trade

I don't mean to spam your thread Nick but i thought you may be interested,I have a guy i use for machine work etc.He has a Segment from a SPZ flywheel and reckons he is going to make a set.

  • Like 4
Untitled-1.png

Link to comment
Share on other sites

1 hour ago, AndrewG said:

What is the issue?

Turning left of centre the steering gets heavy and feels like it’s binding (I can feel it through the floor aswell as the wheel). At the moment everything mechanical checks out (column, UJ, wheels, hubs etc) so I’m going on the assumption it’s something hydraulic.

Link to comment
Share on other sites

1 minute ago, jimmer said:

I don't mean to spam your thread Nick but i thought you may be interested,I have a guy i use for machine work etc.He has a Segment from a SPZ flywheel and reckons he is going to make a set.

Ah nice! Let us know how you get on with them!

Link to comment
Share on other sites

Well on further inspection, I found I’d made a mistake when I reinstalled the rack when replacing the bushes. It appears that I’ve misaligned the column in the UJ, which has thrown the lower UJ out of phase with the upper…. While I’m not 100% sure it’s the cause of my stiff steering, it’s deffo worn out the lower UJ. I removed it today and found it to be free moving but very notchy.

 

hopefully I can source a used replacement in the next day or so and I’ll look at getting a new unit when funds allow (theyre £240 for an OEM replacement!)

Link to comment
Share on other sites

1 hour ago, nickz32 said:

Well on further inspection, I found I’d made a mistake when I reinstalled the rack when replacing the bushes. It appears that I’ve misaligned the column in the UJ, which has thrown the lower UJ out of phase with the upper…. While I’m not 100% sure it’s the cause of my stiff steering, it’s deffo worn out the lower UJ. I removed it today and found it to be free moving but very notchy.

 

hopefully I can source a used replacement in the next day or so and I’ll look at getting a new unit when funds allow (theyre £240 for an OEM replacement!)

I think I have a spare it’s from a 1990 don’t know if N/A or TT if there is a difference.

  • Like 1

1991 Nissan 300zx TT 😎
2002 Porsche 996 3.6 project 🤘

1995 Nissan 300zx TT Crashed 😭

1997 Jaguar XK8 Scraped ☹️

Link to comment
Share on other sites

Small update

 

i borrowed a UJ off a good friend of mine so that my car stays mobile in time for this weekend (BIG milestone coming!)

 

I removed mine and found it was utterly goosed, both notchy and stiff to move in all directions.

 

JoelyP also pointed me in the direction of a recent FB post that identifies 350Z steering UJ’s as identical and half the price of 300zx ones! Nissan U.K. haven’t got any at the moment max but I’ve got one coming from European stocks that will arrive in plenty of time for my road trip in September

000C9E2E-5ECA-4B23-A944-784741F1A01E.png

  • Like 4
Link to comment
Share on other sites

On 15/08/2021 at 21:31, craig said:

Sounds like a road trip needs planning or a driving weekend 🙂

@nickz32

This will be a good trip for the car!

 

 

  • Like 2

1990 Black MT NA LWB = 2014 - 2020 (Sold)

1991 Red MT TT LWB = 2015 - 2017 (Stripped & Scrapped)

1991 Red MT TT LWB = 2017 - 2021 (Sold)

1991 Black MT TT LWB = 2018 - 2021 (Sold)

1989 Red AT TT LWB = 2021 - XXXX (Kept)

Link to comment
Share on other sites

  • 2 weeks later...

Fairly major update

 

the Z went to Abbey motorsport last week for mapping.

 

with fuelling 80% done and boost levels decided upon (1.5 bar) she made 524hp and 519 lb ft at the hubs, which equates to 602hp and 591lbs ft at the crank. Considering that no changes to the base map ignition timing were made, she’s on track to make well over 600hp/lbs ft.

 

however…. We stopped play when the VTC developed a rattle and a slight drop in oil pressure was noticed. We decided to inspect the oil filter and send an oil sample off for analysis to make sure everything was ok

 

unfortunately, I got some bad news today.

 

 

2F9D03ED-4486-424B-81D6-9CAD1513BE57.png

Link to comment
Share on other sites

So yet again, it looks like I’m going to have to strip the engine down and figure out what’s gone wrong and try and deduce why.

 

the oil analysis will tell me if the rich base map has diluted the oil, but due to the time frames and lack of fuel smell from the oil, I’d be very surprised.

 

Highly gutting, but I refuse to let an inanimate object beat me!

Link to comment
Share on other sites

I’ve come to expect the worst when it comes to my luck with this car, and my luck didn’t disappoint.

 

I pulled the engine yesterday, and removed the sump, where I found…


I’m pretty confident that is bearing delamination. There is virtually zero shimmer to the oil, which means that it hasn’t been instigated by bearing to journal contact.

 

what makes things worse is that it appears the issue has taken my turbos with it

 

8C5A766C-0AD2-427A-9264-BD53BAF28804.jpeg

B2385F61-AA7D-4C35-9D94-6635BC34A586.jpeg

BCA610D6-9C7B-4C67-827E-40B1B2502CE6.jpeg

  • Sad 2
  • Angry 1
Link to comment
Share on other sites

I know exactly how you feel mate, i'm on my third rebuild after finding shrapnel in the oil of the first build contaminated my second build.

At the time it also took out my turbos and i had to get them rebuilt too.

I basically had to start again.

 

Hopefully the cause is covered by the engine build warranty.

Link to comment
Share on other sites

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Terms of Use